网络拓扑图:
交换机环境下实现同vlan不能互通却都能访问服务器的两种方法
一、通过hybrid实现可以实现同VLAN不通,却都可以访问服务器。
交换机环境下实现同vlan不能互通却都能访问服务器的两种方法
思路:PC机识别不了VLAN所带的标签,所以PC5想要接收VLAN4所发的数据,就应该在LSW8中的GE 0/0/1的接口
设置取掉VLAN4和VLAN2的标签, 同理,PC6也要取掉VLAN4和VLAN3的标签。而服务器则要取掉所有VLAN的标
签。
1)先按拓扑图添加所需设备并标识出需要设置的VLAN
交换机环境下实现同vlan不能互通却都能访问服务器的两种方法
2)将PC5、PC6、Server的IP依次设定为192.168.1.1、1.2、1.3
子网掩码统一设置为255.255.255.0,标识IP地址
交换机环境下实现同vlan不能互通却都能访问服务器的两种方法
3)首先按照思路配置LSW7的VLAN,命令如下:
systerm-view //进入系统视图
vlan batch 2 3 4 //创建vlan 2 ,3, 4
interface GigaibitEthernet 0/0/1 //进入GE 0/0/1端口
port link type hybrid //配置端口类型为hybrid
port hybrid pvid vlan 4 //配置端口的PVID为VLAN 4
port hybrid untagged vlan 2 3 4 //配置vlan 2,3,4的数据经过端口不加标签
interface GigaibitEthernet 0/0/3 //进入端口GE 0/0/3
port link type hybrid //配置端口类型为hybrid
port hybrid tagged vlan 2 3 4 //配置数据经过GE 0/0/3时都打上标签
输入以上命令后,标识端口的类型
交换机环境下实现同vlan不能互通却都能访问服务器的两种方法
4)配置LSW8上的VLAN,命令如下:
system-view //进入系统视图
vlan batch 2 3 4 //创建vlan 2,3,4
interface GigabitEthernet 0/0/1 //进入端口GE 0/0/1
port link type hybrid //配置端口类型为hybrid
port hybrid pvid vlan 2 //配置端口的PVID为VLAN 2
port hybrid untagged vlan 2 4 //配置vlan 2,4的数据经过端口不加标签
interface GigabitEthernet 0/0/2 //进入端口GE 0/0/2
port link type hybrid //配置端口类型为hybrid
port hybrid pvid vlan 3 //配置端口的PVID为VLAN 3
port hybrid untagged vlan 3 4 //配置vlan 3,4的数据经过端口不加标签
port link type hybrid //配置端口类型为hybrid
interface GigabitEthernet 0/0/3 //进入端口GE 0/0/3
port hybrid tagged vlan 2 3 4 //配置数据经过GE 0/0/3时都打上标签
输入以上命令后,标识端口的类型
交换机环境下实现同vlan不能互通却都能访问服务器的两种方法
5)验证PC5能否ping同Server和PC6,验证结果如下:
交换机环境下实现同vlan不能互通却都能访问服务器的两种方法交换机环境下实现同vlan不能互通却都能访问服务器的两种方法
6)验证PC6能否ping通Server和PC5,验证结果如下:
交换机环境下实现同vlan不能互通却都能访问服务器的两种方法交换机环境下实现同vlan不能互通却都能访问服务器的两种方法
通过以上配置,可以实现同VLAN不通,却都可以访问服务器。
二、通过trunk和hybird实现同VLAN不能互通却都能访问服务器
思路:通过以上实验,我们可以试想一下,既然hybrid为混合端口,那么在两台PC机相连的端口都设置为trunk类型,能否也实现同VLAN不通,却都可以访问服务器。
1)按照上面实验,添加设备以及VLAN标识,IP标识。
交换机环境下实现同vlan不能互通却都能访问服务器的两种方法
2)在LSW1上做以下配置:
systerm-view //进入系统视图
vlan batch 2 3 4 //创建vlan 2,3,4
interface GigabitEthernet 0/0/1 //进入端口GE 0/0/1
port link-type hybrid //将端口设置为hybrid类型
port hybrid pvid vlan 4 //配置端口的PVID为VLAN 4
port hybrid untagged vlan 2 3 4 //经过端口的数据不打vlan 2 ,3,4标签
interface GigaibitEthernet 0/0/3 //进入端口 GE 0/0/3
port link-type trunk //将端口设置为trunk类型
port trunk allow-pass vlan all //允许所有vlan通过
交换机环境下实现同vlan不能互通却都能访问服务器的两种方法
3)在LSW2上做以下配置:
systerm-view //进入系统视图
vlan batch 2 3 4 //创建vlan 2,3,4
interface GigabitEthernet 0/0/1 //进入端口GE 0/0/1
port link-type hybrid //将端口设置为hybrid类型
port hybrid pvid vlan 2 //配置端口的PVID为VLAN 2
port hybrid untagged vlan 2 4 //经过端口的数据不打vlan 2 ,4标签
interface GigabitEthernet 0/0/2 //进入端口GE 0/0/2
port link-type hybrid //将端口设置为hybrid类型
port hybrid pvid vlan 3 //配置端口的PVID为VLAN 3
port hybrid untagged vlan 3 4 //经过端口的数据不打vlan 3,4标签
interface GigaibitEthernet 0/0/3 //进入端口 GE 0/0/3
port link-type trunk //将端口设置为trunk类型
port trunk allow-pass vlan all //允许所有vlan通过
交换机环境下实现同vlan不能互通却都能访问服务器的两种方法
4)验证PC1能否ping同Server和PC2,验证结果如下:
交换机环境下实现同vlan不能互通却都能访问服务器的两种方法交换机环境下实现同vlan不能互通却都能访问服务器的两种方法
5)验证PC2能否ping同Server和PC1,验证结果如下:
交换机环境下实现同vlan不能互通却都能访问服务器的两种方法交换机环境下实现同vlan不能互通却都能访问服务器的两种方法
通过以上实验得知以上假设是成立的。
进一步证明hybrid既可以实现给vlan数据加标签,也可以实现不给vlan加标签。
如果将交换机之间的连接端口设为trunk,也是可以实现可以实现同VLAN不通,却都可以访问服务器。
原因是每个VLAN都设定了PVID,数据从PC机进入交换机时,会被自动打上连接PC机端口的所属的PVID。
所有的交换机有都创建了所有VLAN。trunk允许所有VLAN通过,连接服务器的端口又去掉了VLAN2,3,4的标签,
所以才能在这个拓扑图中,实现同VLAN不通,却都可以访问服务器。