一、实验拓扑图

思科拓扑--链路捆绑的应用


二、什么是链路捆绑?

链路捆绑将多个封装相同链路层协议的接口捆绑到一起,形成一条逻辑上的数据链路。
优点:
1)流量负载分担:出/入流量可以在多个成员接口之间分担。
2)增加带宽:链路捆绑接口的带宽是各可用成员接口带宽的总和。
3)提高连接可靠性:当某个成员接口出现故障时,流量会自动切换到其他可用的成员接口上,从而提高整个捆绑链路的连接可靠性。


三、实验目的

1、4台pc机分别属于不同vlan,如图
2、二层交换机与三层交换机连接的链路实现链路捆绑
3、两台三层交换机实现路由功能
4、两台三层交换机实现DHCP功能
5、使用思科的HSRP实现双机热备份


四、设置配置

1.交换机配置

设备 所属vlan 捆绑的端口 捆绑组号
SW1 vlan10 f0/2-3 1
SW1 vlan10 f0/4-5 4
SW1 vlan10 f0/1
SW2 vlan20 f0/2-3 2
SW2 vlan20 f0/4-5 3
SW2 vlan20 f0/1
SW3 vlan30 f0/2-3 3
SW3 vlan30 f0/4-5 2
SW3 vlan30 f0/1
SW4 vlan40 f0/2-3 4
SW4 vlan40 f0/4-5 1
SW4 vlan40 f0/1

2.路由器配置

a、vlan配置

设备 捆绑接口 所属vlan IP网关 捆绑组号
R1 f0/1-2 vlan10 192.168.1.254/24 1
R1 f0/3-4 vlan20 192.168.2.254/24 2
R1 f0/5-6 vlan30 192.168.3.254/24 3
R1 f0/7-8 vlan40 192.168.4.254/24 4
R2 f0/1-2 vlan40 192.168.4.253/24 4
R2 f0/3-4 vlan30 192.168.3.253/24 3
R2 f0/5-6 vlan20 192.168.2.253/24 2
R2 f0/7-8 vlan10 192.168.1.253/24 1
R1 f0/9-10 192.168.5.1/24 5
R2 f0/9-10 192.168.5.2 /24 5

b、HSRP配置

设备 所属vlan 优先级 虚拟网关
R1 vlan10 150 192.168.1.250
R1 vlan20 150 192.168.2.250
R1 vlan30 150 192.168.3.250
R1 vlan40 150 192.168.4.250
R2 vlan10 100 192.168.1.250
R2 vlan20 100 192.168.2.250
R2 vlan30 100 192.168.3.250
R2 vlan40 100 192.168.4.250

c、dhcp配置

设备 ip网关 ip网段 dns地址 所属vlan
R1/R2 192.168. 1.250 192.168. 1.0/24 8.8.8.8 vlan10
R1/R2 192.168. 2.250 192.168. 2.0/24 8.8.8.8 vlan20
R1/R2 192.168. 3.250 192.168. 3.0/24 8.8.8.8 vlan30
R1/R2 192.168. 4.250 192.168. 4.0/24 8.8.8.8 vlan40

五、配置思路及命令

1.sw1:

A、创建vlan10
B、修改名字为SW1
C、把f0/2-3和f0/4-5捆绑为组1和组4
D、把组1、组4和f0/1加入vlan10

Switch>enable  //进入特权模式
Switch#configure terminal  //进入全局配置模式
Switch(config)#vlan 10 //创建vlan10
Switch(config-vlan)#exit //退出

Switch(config)#hostname SW1 //修改名字为SW1

SW1(config)#interface fastEthernet 0/1  //进入接口f0/1
SW1(config-if)#switchport mode access  //设置为接入模式
SW1(config-if)#switchport access vlan 10  //把vlan10接入
SW1(config-if)#exit //退出

SW1(config)#interface range fastEthernet 0/2-3  //进入接口f0/2-3
SW1(config-if-range)#channel-protocol lacp //设置捆绑协议为LACP
SW1(config-if-range)#channel-group 1 mode active  //设置捆绑组1模式为主动寻找
SW1(config-if-range)#exit //退出

SW1(config)#interface range fastEthernet 0/4-5 //进入接口f0/4-5
SW1(config-if-range)#channel-protocol lacp //设置捆绑协议为LACP
SW1(config-if-range)#channel-group 4 mode active  //设置捆绑组4模式为主动寻找
SW1(config-if-range)#exit //退出

SW1(config)#interface port-channel 1  //进入捆绑组1
SW1(config-if)#switchport mode access  //设置为接入模式
SW1(config-if)#switchport access vlan 10 //把vlan10接入
SW1(config-if)#exit //退出

SW1(config)#interface port-channel 4 //进入捆绑组4
SW1(config-if)#switchport mode access  //设置为接入模式
SW1(config-if)#switchport access vlan 10 //把vlan10接入
SW1(config-if)#exit //退出

验证:SW1#show vlan brief//查看vlan
思科拓扑--链路捆绑的应用

2.sw2:

A、创建vlan20
B、修改名字为SW2
C、把f0/2-3和f0/4-5捆绑为组2和组3
D、把组2、组3和f0/1加入vlan20

Switch>enable  //进入特权模式
Switch#configure terminal  //进入全局配置模式
Switch(config)#vlan 20 //创建vlan20
Switch(config-vlan)#exit //退出

Switch(config)#hostname SW2 //修改名字为SW2

SW2(config)#interface fastEthernet 0/1  //进入接口f0/1
SW2(config-if)#switchport mode access  //设置为接入模式
SW2(config-if)#switchport access vlan 20  //把vlan20接入
SW2(config-if)#exit //退出

SW2(config)#interface range fastEthernet 0/2-3  //进入接口f0/2-3
SW2(config-if-range)#channel-protocol lacp //设置捆绑协议为LACP
SW2(config-if-range)#channel-group 2 mode active  //设置捆绑组2模式为主动寻找
SW2(config-if-range)#exit //退出

SW2(config)#interface range fastEthernet 0/4-5 //进入接口f0/4-5
SW2(config-if-range)#channel-protocol lacp //设置捆绑协议为LACP
SW2(config-if-range)#channel-group 3 mode active  //设置捆绑组3模式为主动寻找
SW2(config-if-range)#exit //退出

SW2(config)#interface port-channel 2  //进入捆绑组2
SW2(config-if)#switchport mode access  //设置为接入模式
SW2(config-if)#switchport access vlan 20 //把vlan20接入
SW2(config-if)#exit //退出

SW2(config)#interface port-channel 3 //进入捆绑组3
SW2(config-if)#switchport mode access  //设置为接入模式
SW2(config-if)#switchport access vlan 20 //把vlan20接入
SW2(config-if)#exit //退出

验证:SW2#show vlan brief//查看vlan
思科拓扑--链路捆绑的应用

3.sw3:

A、创建vlan30
B、修改名字为SW3
C、把f0/2-3和f0/4-5捆绑为组3和组2
D、把组3、组2和f0/1加入vlan30

Switch>enable  //进入特权模式
Switch#configure terminal  //进入全局配置模式
Switch(config)#vlan 30 //创建vlan30
Switch(config-vlan)#exit //退出

Switch(config)#hostname SW3 //修改名字为SW3

SW3(config)#interface fastEthernet 0/1  //进入接口f0/1
SW3(config-if)#switchport mode access  //设置为接入模式
SW3(config-if)#switchport access vlan 30  //把vlan30接入
SW3(config-if)#exit //退出

SW3(config)#interface range fastEthernet 0/2-3  //进入接口f0/2-3
SW3(config-if-range)#channel-protocol lacp //设置捆绑协议为LACP
SW3(config-if-range)#channel-group 3 mode active  //设置捆绑组3模式为主动寻找
SW3(config-if-range)#exit //退出

SW3(config)#interface range fastEthernet 0/4-5 //进入接口f0/4-5
SW3(config-if-range)#channel-protocol lacp //设置捆绑协议为LACP
SW3(config-if-range)#channel-group 2 mode active  //设置捆绑组2模式为主动寻找
SW3(config-if-range)#exit //退出

SW3(config)#interface port-channel 3  //进入捆绑组3
SW3(config-if)#switchport mode access  //设置为接入模式
SW3(config-if)#switchport access vlan 30 //把vlan30接入
SW3(config-if)#exit //退出

SW3(config)#interface port-channel 2 //进入捆绑组2
SW3(config-if)#switchport mode access  //设置为接入模式
SW3(config-if)#switchport access vlan 30 //把vlan30接入
SW3(config-if)#exit //退出

验证:SW3#show vlan brief//查看vlan
思科拓扑--链路捆绑的应用

4.sw4:

A、创建vlan40
B、修改名字为SW4
C、把f0/2-3和f0/4-5捆绑为组4和组1
D、把组4、组1和f0/1加入vlan40

Switch>enable  //进入特权模式
Switch#configure terminal  //进入全局配置模式
Switch(config)#vlan 40 //创建vlan40
Switch(config-vlan)#exit //退出

Switch(config)#hostname SW4 //修改名字为SW4

SW4(config)#interface fastEthernet 0/1  //进入接口f0/1
SW4(config-if)#switchport mode access  //设置为接入模式
SW4(config-if)#switchport access vlan 40  //把vlan40接入
SW4(config-if)#exit //退出

SW4(config)#interface range fastEthernet 0/2-3  //进入接口f0/2-3
SW4(config-if-range)#channel-protocol lacp //设置捆绑协议为LACP
SW4(config-if-range)#channel-group 4 mode active  //设置捆绑组1模式为主动寻找
SW4(config-if-range)#exit //退出

SW4(config)#interface range fastEthernet 0/4-5 //进入接口f0/4-5
SW4(config-if-range)#channel-protocol lacp //设置捆绑协议为LACP
SW4(config-if-range)#channel-group 1 mode active  //设置捆绑组1模式为主动寻找
SW4(config-if-range)#exit //退出

SW4(config)#interface port-channel 4  //进入捆绑组4
SW4(config-if)#switchport mode access  //设置为接入模式
SW4(config-if)#switchport access vlan 40 //把vlan40接入
SW4(config-if)#exit //退出

SW4(config)#interface port-channel 1 //进入捆绑组1
SW4(config-if)#switchport mode access  //设置为接入模式
SW4(config-if)#switchport access vlan 40 //把vlan40接入
SW4(config-if)#exit //退出

验证:SW4#show vlan brief//查看vlan
思科拓扑--链路捆绑的应用

5.R1:

A、创建vlan10、20、30、40
B、开启路由功能,设置vlan10、20、30、40网关
C、把端口f0/1-2捆绑加入vlan10,把端口f0/3-4捆绑加入vlan20,把端口f0/5-6捆绑加入vlan30,把端口f0/7-8捆绑加入vlan40,把端口f0/9-10捆绑设置ip网关且设置缺省路由
D、开启dhcp功能,设置四个地址池,分别对应四个vlan
E、设置HSRP优先级为150

Switch>enable //进入特权模式
Switch#configure terminal  //进入全局配置模式

Switch(config)#hostname R1  //修改名字为R1

R1(config)#vlan 10  //创建vlan10
R1(config-vlan)#vlan 20 //创建vlan20
R1(config-vlan)#vlan 30 //创建vlan30
R1(config-vlan)#vlan 40 //创建vlan40  
R1(config-vlan)#exit //退出

R1(config)#ip routing //开启路由功能

R1(config)#interface vlan 10  //进入vlan10
R1(config-if)#no shutdown  //开启端口
R1(config-if)#ip address 192.168.1.254 255.255.255.0 //设置vlan10的网关
R1(config-if)#exit  //退出

R1(config)#interface vlan 20 //进入vlan20
R1(config-if)#no shutdown  //开启端口
R1(config-if)#ip address 192.168.2.254 255.255.255.0 //设置vlan20的网关
R1(config-if)#exit  //退出

R1(config)#interface vlan 30 //进入vlan30
R1(config-if)#no shutdown //开启端口
R1(config-if)#ip address 192.168.3.254 255.255.255.0 //设置vlan30的网关
R1(config-if)#exit //退出

R1(config)#interface vlan 40 //进入vlan40
R1(config-if)#no shutdown  //开启端口
R1(config-if)#ip address 192.168.4.254 255.255.255.0 //设置vlan40的网关
R1(config-if)#exit  //退出

R1(config)#interface range fastEthernet 0/1-2  //进入接口f0/1-2
R1(config-if-range)#channel-protocol lacp //设置捆绑协议为lacp
R1(config-if-range)#channel-group 1 mode active //设置捆绑组1为主动模式
R1(config-if-range)#exit //退出

R1(config)#interface port-channel 1  //进入捆绑组1
R1(config-if)#switchport mode access //设置为接入模式
R1(config-if)#switchport access vlan 10 //把vlan10接入
R1(config-if)#exit //退出

R1(config)#interface range fastEthernet 0/3-4 //进入接口f0/3-4
R1(config-if-range)#channel-protocol lacp //设置捆绑协议为lacp
R1(config-if-range)#channel-group 2 mode active  //设置捆绑组2为主动模式
R1(config-if-range)#exit  //退出

R1(config)#interface port-channel 2 //进入捆绑组2
R1(config-if)#switchport mode access //设置为接入模式
R1(config-if)#switchport access vlan 20 //把vlan20接入
R1(config-if)#exit  //退出

R1(config)#interface range fastEthernet 0/5-6 //进入接口f0/5-6
R1(config-if-range)#channel-protocol lacp //设置捆绑协议为lacp
R1(config-if-range)#channel-group 3 mode active //设置捆绑组3为主动模式
R1(config-if-range)#exit  //退出

R1(config)#interface port-channel 3 //进入捆绑组3
R1(config-if)#switchport mode access //设置为接入模式
R1(config-if)#switchport access vlan 30 //把vlan30接入
R1(config-if)#exit  //退出

R1(config)#interface range fastEthernet 0/7-8 //进入接口f0/7-8
R1(config-if-range)#channel-protocol lacp //设置捆绑协议为lacp
R1(config-if-range)#channel-group 4 mode active  //设置捆绑组4为主动模式
R1(config-if-range)#exit //退出

R1(config)#interface port-channel 4 //进入捆绑组4
R1(config-if)#switchport mode access  //设置为接入模式
R1(config-if)#switchport access vlan 40 //把vlan40接入
R1(config-if)#exit //退出

R1(config)#interface range fastEthernet 0/9-10 //进入接口f0/9-10
R1(config-if-range)#channel-protocol lacp //设置捆绑协议为lacp
R1(config-if-range)#channel-group 5 mode active  //设置捆绑组5为主动模式
R1(config-if-range)#exit //退出

R1(config)#interface port-channel 5 //进入捆绑组5
R1(config-if)#no switchport //关闭二层交换机功能
R1(config-if)#ip address 192.168.5.1 255.255.255.0 //设置网关
R1(config-if)#exit //退出

R1(config)#ip route 0.0.0.0 0.0.0.0 192.168.5.2  //设置缺省路由吓一跳为192.168.5.2

R1(config)#service dhcp //开启dhcp功能

R1(config)#ip dhcp pool vlan10 //开启地址池vlan10
R1(dhcp-config)#network 192.168.1.0 255.255.255.0 //设置vlan10的网段
R1(dhcp-config)#default-router 192.168.1.250  //设置vlan10的网关R1(dhcp-config)#dns-server 8.8.8.8 //设置vlan10的dns地址
R1(dhcp-config)#exit //退出

R1(config)#ip dhcp pool vlan20 //开启地址池vlan20
R1(dhcp-config)#network 192.168.2.0 255.255.255.0 //设置vlan20的网段
R1(dhcp-config)#default-router 192.168.2.250 //设置vlan20的网关
R1(dhcp-config)#dns-server 8.8.8.8  //设置vlan20的dns地址
R1(dhcp-config)#exit //退出

R1(config)#ip dhcp pool vlan30 //开启地址池vlan30
R1(dhcp-config)#network 192.168.3.0 255.255.255.0 //设置vlan30的网段
R1(dhcp-config)#default-router 192.168.3.250 //设置vlan30的网关
R1(dhcp-config)#dns-server 8.8.8.8 //设置vlan30的dns地址
R1(dhcp-config)#exit //退出

R1(config)#ip dhcp pool vlan40 //开启地址池vlan40 
R1(dhcp-config)#network 192.168.4.0 255.255.255.0//设置vlan40的网段
R1(dhcp-config)#default-router 192.168.4.250 //设置vlan40的网关
R1(dhcp-config)#dns-server 8.8.8.8 //设置vlan40的dns地址
R1(dhcp-config)#exit //退出

R1(config)#int vlan 10 //进入vlan10
R1(config-if)#standby 1 ip 192.168.1.250 //设置HSRP组1的虚拟网关
R1(config-if)#standby 1 priority 150 //设置HSRP的优先级为150
R1(config-if)#standby 1 preempt //开启抢占功能
R1(config-if)#exit //退出

R1(config)#int vlan 20  //进入vlan20
R1(config-if)#standby 2 ip 192.168.2.250 //设置HSRP组2的虚拟网关
R1(config-if)#standby 2 priority 150 //设置HSRP的优先级为150
R1(config-if)#standby 2 preempt  //开启抢占功能
R1(config-if)#exit//退出

R1(config)#int vlan 30 //进入vlan30
R1(config-if)#standby 3 ip 192.168.3.250 //设置HSRP组3的虚拟网关
R1(config-if)#standby 3 priority 150 //设置HSRP的优先级为150
R1(config-if)#standby 3 preempt  //开启抢占功能
R1(config-if)#exit //退出

R1(config)#int vlan 40 //进入vlan40
R1(config-if)#standby 4 ip 192.168.4.250 //设置HSRP组4的虚拟网关
R1(config-if)#standby 4 priority 150 //设置HSRP的优先级为150
R1(config-if)#standby 4 preempt  //开启抢占功能
R1(config-if)#exit //退出

验证:R1#show vlan brief //查看vlan
思科拓扑--链路捆绑的应用
R1#show running-config //查看所有配置
思科拓扑--链路捆绑的应用
思科拓扑--链路捆绑的应用
思科拓扑--链路捆绑的应用
思科拓扑--链路捆绑的应用
思科拓扑--链路捆绑的应用
思科拓扑--链路捆绑的应用

6.R2:

A、创建vlan10、20、30、40
B、开启路由功能,设置vlan10、20、30、40网关
C、把端口f0/1-2捆绑加入vlan10,把端口f0/3-4捆绑加入vlan20,把端口f0/5-6捆绑加入vlan30,把端口f0/7-8捆绑加入vlan40,把端口f0/9-10捆绑设置ip网关且设置缺省路由
D、开启dhcp功能,设置四个地址池,分别对应四个vlan
E、设置HSRP优先级为100

Switch>enable //进入特权模式
Switch#configure terminal  //进入全局配置模式

Switch(config)#hostname R2  //修改名字为R2

R2(config)#vlan 10  //创建vlan10
R2(config-vlan)#vlan 20 //创建vlan20
R2(config-vlan)#vlan 30 //创建vlan30
R2(config-vlan)#vlan 40 //创建vlan40  
R2(config-vlan)#exit //退出

R2(config)#ip routing //开启路由功能

R2(config)#interface vlan 10  //进入vlan10
R2(config-if)#no shutdown  //开启端口
R2(config-if)#ip address 192.168.1.253 255.255.255.0 //设置vlan10的网关
R2(config-if)#exit  //退出

R2(config)#interface vlan 20 //进入vlan20
R2(config-if)#no shutdown  //开启端口
R2(config-if)#ip address 192.168.2.253 255.255.255.0 //设置vlan20的网关
R2(config-if)#exit  //退出

R2(config)#interface vlan 30 //进入vlan30
R2(config-if)#no shutdown //开启端口
R2(config-if)#ip address 192.168.3.253 255.255.255.0 //设置vlan30的网关
R2(config-if)#exit //退出

R2(config)#interface vlan 40 //进入vlan40
R2(config-if)#no shutdown  //开启端口
R2(config-if)#ip address 192.168.4.253 255.255.255.0 //设置vlan40的网关
R2(config-if)#exit  //退出

R2(config)#interface range fastEthernet 0/1-2  //进入接口f0/1-2
R2(config-if-range)#channel-protocol lacp //设置捆绑协议为lacp
R2(config-if-range)#channel-group 1 mode active //设置捆绑组1为主动模式
R2(config-if-range)#exit //退出

R2(config)#interface port-channel 1  //进入捆绑组1
R2(config-if)#switchport mode access //设置为接入模式
R2(config-if)#switchport access vlan 10 //把vlan10接入
R2(config-if)#exit //退出

R2(config)#interface range fastEthernet 0/3-4 //进入接口f0/3-4
R2(config-if-range)#channel-protocol lacp //设置捆绑协议为lacp
R2(config-if-range)#channel-group 2 mode active  //设置捆绑组2为主动模式
R2(config-if-range)#exit  //退出

R2(config)#interface port-channel 2 //进入捆绑组2
R2(config-if)#switchport mode access //设置为接入模式
R2(config-if)#switchport access vlan 20 //把vlan20接入
R2(config-if)#exit  //退出

R2(config)#interface range fastEthernet 0/5-6 //进入接口f0/5-6
R2(config-if-range)#channel-protocol lacp //设置捆绑协议为lacp
R2(config-if-range)#channel-group 3 mode active //设置捆绑组3为主动模式
R2(config-if-range)#exit  //退出

R2(config)#interface port-channel 3 //进入捆绑组3
R2(config-if)#switchport mode access //设置为接入模式
R2(config-if)#switchport access vlan 30 //把vlan30接入
R2(config-if)#exit  //退出

R2(config)#interface range fastEthernet 0/7-8 //进入接口f0/7-8
R2(config-if-range)#channel-protocol lacp //设置捆绑协议为lacp
R2(config-if-range)#channel-group 4 mode active  //设置捆绑组4为主动模式
R2(config-if-range)#exit //退出

R2(config)#interface port-channel 4 //进入捆绑组4
R2(config-if)#switchport mode access  //设置为接入模式
R2(config-if)#switchport access vlan 40 //把vlan40接入
R2(config-if)#exit //退出

R2(config)#interface range fastEthernet 0/9-10 //进入接口f0/9-10
R2(config-if-range)#channel-protocol lacp //设置捆绑协议为lacp
R2(config-if-range)#channel-group 5 mode active  //设置捆绑组5为主动模式
R2(config-if-range)#exit //退出

R2(config)#interface port-channel 5 //进入捆绑组5
R2(config-if)#no switchport //关闭二层交换机功能
R2(config-if)#ip address 192.168.5.2 255.255.255.0 //设置网关
R2(config-if)#exit //退出

R2(config)#ip route 0.0.0.0 0.0.0.0 192.168.5.1  //设置缺省路由吓一跳为192.168.5.1

R2(config)#service dhcp //开启dhcp功能

R2(config)#ip dhcp pool vlan10 //开启地址池vlan10
R2(dhcp-config)#network 192.168.1.0 255.255.255.0 //设置vlan10的网段
R2(dhcp-config)#default-router 192.168.1.250  //设置vlan10的网关R2(dhcp-config)#dns-server 8.8.8.8 //设置vlan10的dns地址
R2(dhcp-config)#exit //退出

R2(config)#ip dhcp pool vlan20 //开启地址池vlan20
R2(dhcp-config)#network 192.168.2.0 255.255.255.0 //设置vlan20的网段
R2(dhcp-config)#default-router 192.168.2.250 //设置vlan20的网关
R2(dhcp-config)#dns-server 8.8.8.8  //设置vlan20的dns地址
R2(dhcp-config)#exit //退出

R2(config)#ip dhcp pool vlan30 //开启地址池vlan30
R2(dhcp-config)#network 192.168.3.0 255.255.255.0 //设置vlan30的网段
R2(dhcp-config)#default-router 192.168.3.250 //设置vlan30的网关
R2(dhcp-config)#dns-server 8.8.8.8 //设置vlan30的dns地址
R2(dhcp-config)#exit //退出

R2(config)#ip dhcp pool vlan40 //开启地址池vlan40 
R2(dhcp-config)#network 192.168.4.0 255.255.255.0//设置vlan40的网段
R2(dhcp-config)#default-router 192.168.4.250 //设置vlan40的网关
R2(dhcp-config)#dns-server 8.8.8.8 //设置vlan40的dns地址
R2(dhcp-config)#exit //退出

R2(config)#int vlan 10 //进入vlan10
R2(config-if)#standby 1 ip 192.168.1.250 //设置HSRP组1的虚拟网关
R2(config-if)#standby 1 priority 100 //设置HSRP的优先级为100
R2(config-if)#standby 1 preempt //开启抢占功能
R2(config-if)#exit //退出

R2(config)#int vlan 20  //进入vlan20
R2(config-if)#standby 2 ip 192.168.2.250 //设置HSRP组2的虚拟网关
R2(config-if)#standby 2 priority 100 //设置HSRP的优先级为100
R2(config-if)#standby 2 preempt  //开启抢占功能
R2(config-if)#exit//退出

R2(config)#int vlan 30 //进入vlan30
R2(config-if)#standby 3 ip 192.168.3.250 //设置HSRP组3的虚拟网关
R2(config-if)#standby 3 priority 100 //设置HSRP的优先级为100
R2(config-if)#standby 3 preempt  //开启抢占功能
R2(config-if)#exit //退出

R2(config)#int vlan 40 //进入vlan40
R2(config-if)#standby 4 ip 192.168.4.250 //设置HSRP组4的虚拟网关
R2(config-if)#standby 4 priority 100 //设置HSRP的优先级为100
R2(config-if)#standby 4 preempt  //开启抢占功能
R2(config-if)#exit //退出

验证:R2#show vlan brief //查看vlan
思科拓扑--链路捆绑的应用
R2#show running-config //查看所有配置
思科拓扑--链路捆绑的应用
思科拓扑--链路捆绑的应用
思科拓扑--链路捆绑的应用
思科拓扑--链路捆绑的应用
思科拓扑--链路捆绑的应用
思科拓扑--链路捆绑的应用
思科拓扑--链路捆绑的应用

7.pc机验证:

思科拓扑--链路捆绑的应用
思科拓扑--链路捆绑的应用
思科拓扑--链路捆绑的应用
思科拓扑--链路捆绑的应用

pc机ping通详情

思科拓扑--链路捆绑的应用
思科拓扑--链路捆绑的应用
思科拓扑--链路捆绑的应用

8.vrrp:

R1优先级大使用R1的路由器
思科拓扑--链路捆绑的应用