一、拓扑图展示--思科版的单臂路由
思科拓扑--单臂路由


二、实验目的

  1. 实现交换机换分两个vlan10和vlan20
  2. 实现路由器的单臂功能,把接口gig0/0划分为gig0/0.1和gig0/0.2并且分配网关
  3. 给电脑配置静态ip
  4. 实现两台pc机的连接

三、所需设备以及相关设置
两台pc机、一台交换机、一台路由器、三根直通线
1.1.Pc机设置

pc机 ip地址 子网掩码 ip网关
pc1 192.168.1.1 255.255.255.0 192.168.1.254
pc2 192.168.2.1 255.255.255.0 192.168.2.254

2.交换机设置

接口 vlan模式 所属vlan
fastethernet0/2 access vlan10
fastethernet0/3 access vlan20
fastethernet0/1 trunk vlan all

3.路由器设置

虚拟子接口 封装协议 所属vlan 网关
g0/0.1 dot1q vlan10 192.168.1.254
g0/0.2 dot1q vlan20 192.168.2.254

四、配置思路以及代码展示
1.SW配置思路:创建两个vlan10和vlan20,分别access模式加入端口2和3,端口1设置trunk模式。

Switch>enable //进入特权模式
Switch#configure terminal //进入全局配置模式

Switch(config)#vlan 10 //创建vlan10
Switch(config-vlan)#exit //退出
Switch(config)#vlan 20 //创建vlan20
Switch(config-vlan)#exit //退出

Switch(config)#interface fastEthernet 0/2 //进入接口f0/2
Switch(config-if)#switchport mode access //设置为接入模式
Switch(config-if)#switchport access vlan 10 //把vlan10划分进去
Switch(config-vlan)#exit //退出

Switch(config)#interface fastEthernet 0/3 //进入接口f0/3
Switch(config-if)#switchport mode access //设置为接入模式
Switch(config-if)#switchport access vlan 20 //把vlan20划分进去
Switch(config-vlan)#exit //退出

Switch(config)#interface fastEthernet 0/1 //进入接口f0/1
Switch(config-if)#switchport mode trunk // //设置为中继模式(思科中继默认是属于所vlan的)

2.R1路由器设置思路:设置单臂路由器子端口gig0/0.1,设置子端口协议为802.1q并把端口划分到vlan10中(思科由两种协议可以使用一个是802.1q协议、一个是isl协议),设置ip网关,开启子接口ARP(地址解析协议)广播。设置单臂路由器子端口gig0/0.2,设置子端口协议为802.1q并把端口划分到vlan20中,设置ip网关,开启子接口ARP(地址解析协议)广播。

Router>enable //进入特权模式
Router#config terminal //进入全局配置模式

Router(config)#interface gigabitethernet 0/0 //进入端口gig0/0
Router(config-if)#no shutdown //开启端口(默认思科路由器是关闭的)
Router(config-if)#exit //退出

Router(config)#interface gigabitEthernet 0/0.1 //开启子端口gig0/0.1
Router(config-subif)#no shutdown //习惯性的开启端口
Router(config-subif)#encapsulation dot1Q 10 //为接口设置802.1q协议最后面的是vlan 号(划分进入vlan 10),注意:注意一定要先封装协议,在配置ip
Router(config-subif)#ip address 192.168.1.254 255.255.255.0 //设置vlan 10的ip路由地址
Router(config-subif)#exit //退出
注:思科是自动开启rap广播的。

Router(config)#interface gigabitEthernet 0/0.2 //开启子端口gig0/0.2
Router(config-subif)#no shutdown //习惯性的开启端口
Router(config-subif)#encapsulation dot1Q 20 //为接口设置802.1q协议最后面的是vlan 号(划分进入vlan 20),注意:注意一定要先封装协议,在配置ip
Router(config-subif)#ip address 192.168.2.254 255.255.255.0 //设置vlan 20的ip路由地址
Router(config-subif)#exit //退出

五、检测截图和检测命令截图
1.LSW1验证Switch#show vlan brief //查看vlan
思科拓扑--单臂路由
Switch#show interfaces trunk //查看所属trunk的接口
思科拓扑--单臂路由
2.路由器查看子端口配置Router#show running-config //查看所有配置
思科拓扑--单臂路由
3.pc机ping的情况
思科拓扑--单臂路由