一、前言
我在网络中也查询了一些单臂路由的配置思路,写的都不是很详细,配置思路对小白来说不是很清晰了解,再此写一篇针对我这种小白学习的文章,了解什么是单臂路由。首先单臂路由能够实现什么?在公司中,因为资金紧张就只有一台路由器,但是公司的交换机划分了多了vlan(虚拟局域网),可是路由器的接口只有两个,一个用来连接外网,一个用来连接内网。那么内网的网关接口就不够用了,因此我们需要在路由器的接口上通过配置“逻辑接口(并不存在的真正物理接口)”也叫子接口,来实现多vlan的网关互通。注:这个是华为版本后面我会写思科的版本。


二、拓扑图展示
华为拓扑--路由器的单臂路由应用


三、实验目的

  1. 实现交换机划分两个vlan10和vlan20
    1. 实现路由器的单臂功能,把接口g0/0/0划分为g0/0/0.1和g0/0/0.2并且分配网关
    2. 给电脑配置静态ip
    3. 实现两台pc机的连接

四、所需设备以及相关设置
两台pc机、一台交换机、一台路由器、三根直通线
1.1.Pc机设置

pc机 ip地址 子网掩码 ip网关
pc1 192.168.1.1 255.255.255.0 192.168.1.254
pc2 192.168.2.1 255.255.255.0 192.168.2.254

2.交换机设置

接口 vlan模式 所属vlan
Ethernet0/0/2 access vlan10
Ethernet0/0/3 access vlan20
Ethernet0/0/1 trunk vlan all

3.路由器设置

虚拟子接口 封装协议 所属vlan 网关
g0/0/0.1 dot1q vlan10 192.168.1.254
g0/0/0.2 dot1q vlan20 192.168.2.254

五、配置思路以及代码展示
1.LSW配置思路:创建两个vlan10和vlan20,分别access模式加入端口2和3,端口1设置trunk模式。

<Huawei>system-view  //进入系统模式
[Huawei]vlan batch 10 20 //创建vlan10和20

[Huawei]interface Ethernet 0/0/2  //进入端口Ethernet 0/0/2
[Huawei-Ethernet0/0/2]port link-type access //设置模式为接入
[Huawei-Ethernet0/0/2]port default vlan 10 //把vlan10划入
[Huawei-Ethernet0/0/2]quit //退出

[Huawei]interface Ethernet 0/0/3  //进入端口Ethernet 0/0/3
[Huawei-Ethernet0/0/3]port link-type access  //设置模式为接入
[Huawei-Ethernet0/0/3]port default vlan 20 //把vlan20划入
[Huawei-Ethernet0/0/3]quit //退出

[Huawei]interface Ethernet 0/0/1  //进入端口Ethernet 0/0/1
[Huawei-Ethernet0/0/1]port link-type trunk //设置模式为中继
[Huawei-Ethernet0/0/1]port trunk allow-pass vlan all //设置中继所有vlan
[Huawei-Ethernet0/0/3]quit //退出

2.AR1路由器设置思路:设置单臂路由器子端口g0/0/0.1,设置子端口协议为802.1q并把端口划分到vlan10中,设置ip网关,开启子接口ARP广播。设置单臂路由器子端口g0/0/0.2,设置子端口协议为802.1q并把端口划分到vlan20中,设置ip网关,开启子接口ARP广播。

<Huawei>system-view  //进入系统模式

[Huawei]interface GigabitEthernet 0/0/0.1 //开启子端口 G0/0/0.1
[Huawei-GigabitEthernet0/0/0.1]dot1q termination vid 10 //封装dot1q协议,设置子接口对应vlan 10
[Huawei-GigabitEthernet0/0/0.1]ip address 192.168.1.254 24 //设置vlan 10的网关
[Huawei-GigabitEthernet0/0/0.1]arp broadcast  enable //开启子接口的ARP广播
[Huawei-GigabitEthernet0/0/0.1]quit //退出

[Huawei]interface GigabitEthernet 0/0/0.2 //开启子端口 G0/0/0.2
[Huawei-GigabitEthernet0/0/0.2]dot1q termination vid 20 //封装dot1q协议,设置子接口对应vlan 20
[Huawei-GigabitEthernet0/0/0.1]arp broadcast  enable //开启子接口的ARP广播

[Huawei-GigabitEthernet0/0/0.2]ip address 192.168.2.254 24  //设置vlan 20的网关
[Huawei-GigabitEthernet0/0/0.2]quit //退出

六、检测截图和检测命令截图
1.LSW1验证[Huawei]display vlan //验证vlan和接口创建
华为拓扑--路由器的单臂路由应用
2.路由器查看子端口配置[Huawei]display interface brief //查看接口配置表
华为拓扑--路由器的单臂路由应用
[Huawei]display current-configuration//查看所有配置,看地址配置信息
华为拓扑--路由器的单臂路由应用
3.pc机ping的情况
华为拓扑--路由器的单臂路由应用