一、实验案例
思科拓扑--小型公司案例实施和思路。


二、配置拓扑图
思科拓扑--小型公司案例实施和思路。


三、实验目的
1.划分一下公司所需要使用的子网网段和子网掩码
2.让三层交换机实现dhcp和路由功能
3.让二层交换机划分vlan10、vlan20、vlan30、 vlan40
4.实现底层pc机能够使用dhcp划分的网段ip


四、子网划分思路
1.首先确定每个vlan需要的主机数量,从主机数量最多的开始分配ip段
2.(1)Vlan20需要90台主机,因此首先要划分vlan20的子网,vlan20至少需要90+2的主机位,
因此至少要使用主机位后7位,也就是128个主机位,空出1位划分子网,可划分为两个网段

网段192.168.22.0000 0000   192.168.22.0 /25  
子网掩码为 255.255.255.128
网络id 192.168.22.0 
广播192.168.22.127 
可用主机地址192.168.22.1到192.168.22.126
网段192.168.22.1000 0000   192.168.22.128 /25 
子网掩码为 255.255.255.128
网络id 192.168.22.128 
广播192.168.22.255 
可用主机地址192.168.22.129到192.168.22.254

使用第一个网段即可。留下的网段给其他主机分配。


(2)其次我们看vlan10需要50台主机,与上面分析是一样的,至少需要50+2台主机位,
因此至少要使用主机位后6位,也就是64个主机位,空出2位划分子网,可划分为4个网段,
因为vlan10已经使用了前128的主机位,只能在后面剩下的主机位中选取,那么可使用的网段为

网段192.168.22.1000 0000  192.168.22.128 /26  
子网掩码为 255.255.255.192
网络id 192.168.22.128 
广播192.168.22.191 
可用主机地址192.168.22.129到192.168.22.190 
网段192.168.22.1100 0000  192.168.22.192/26  
子网掩码为 255.255.255.192
网络id 192.168.22.192
广播192.168.22.255 
可用主机地址192.168.22.193到192.168.22. 254

使用第一个网段即可。留下的网段给其他主机分配。


(3)其次我们看vlan40需要26台主机,与上面分析是一样的,至少需要26+2台主机位,
因此至少要使用主机位后5位,也就是32个主机位,空出3位划分子网,可划分为8个网段,
因为前面已经使用了192个主机位了,只能在后面剩下的主机位中选取,那么可使用的网段为

网段192.168.22.1100 0000   192.168.22.192 /26
子网掩码为 255.255.255.224
网络id 192.168.22.192 
广播192.168.22.223 
可用主机地址192.168.22.193到192.168.22.222
网段192.168.22.1110 0000   192.168.22.224 /26
子网掩码为 255.255.255.224
网络id 192.168.22.224 
广播192.168.22.255
可用主机地址192.168.22.225到192.168.22.254

使用第一个网段即可。留下的网段给其他主机分配。


(4)剩下vlan30需要15台主机,这里可以直接使用后面剩下的网段,
也可以进一步的划分直接使用即可

网段192.168.22.1110 0000   192.168.22.224 /26
子网掩码为 255.255.255.224
网络id 192.168.22.224 
广播192.168.22.255 
可用主机地址192.168.22.225到192.168.22.254 

五、所需设备以及相关设置
4台pc机、2台交换机、1台三层交换、2根交叉线、4根直通线,链接如拓扑图。
1.4台Pc机设置dhcp
2.交换机接口设置

设备 接口 所属vlan和模式
SW1 f0/2 acc vlan10
SW1 f0/3 acc vlan20
SW1 f0/1 trunk
SW2 f0/2 acc vlan30
SW2 f0/3 acc vlan40
SW2 f0/1 trunk
SW3 f0/1 f0/2 trunk

3.sw3交换机 vlan网关设置和地址池设置

vlan 网段 广播地址 可用ip地址范围 网关
vlan10 192.168.22.128/26 192.168.22.191 192.168.22.129~192.168.22.190 192.168.22.190
vlan20 192.168.22.0/25 192.168.22.127 192.168.22.1~192.168.22.126 192.168.22.126
vlan30 192.168.22.192./27 192.168.22.223 192.168.22.193~192.168.22.222 192.168.22.222
vlan40 192.168.22.224/27 192.168.22.255 192.168.22.225~192.168.22.254 192.168.22.254

六、配置思路以及代码展示
1.SW1配置思路:设置vlan10和vlan20,把端口f0/2模式access添加进入vlan10,端口f0/3模式access添加进入vlan20,端口f0/1设置trunk模式

Switch>enable //进入特权模式
Switch#config terminal //进入全局配置模式

Switch(config)#vlan 10 //创建vlan10
Switch(config-vlan)#exit //退出
Switch(config)#vlan 20 //创建vlan20
Switch(config-vlan)#exit //退出

Switch(config)#int fastEthernet 0/2  //进入端口f0/2
Switch(config-if)#switchport mode access //设置接入模式
Switch(config-if)#switchport access vlan 10 //将接口加入vlan10
Switch(config-if)#exit //退出

Switch(config)#int fastEthernet 0/3 //进入端口f0/3
Switch(config-if)# switchport mode access //设置接入模式
Switch(config-if)# switchport access vlan 20 //将接口加入vlan20
Switch(config-if)# exit //退出

Switch(config)#int fastEthernet 0/1 //进入端口f0/1
Switch(config-if)#switchport mode trunk  //设置为中继模式

2.SW2配置思路:设置vlan30和vlan40,把端口f0/2模式access添加进入vlan30,端口f0/3模式access添加进入vlan40,端口f0/1设置trunk模式

Switch>enable //进入特权模式
Switch#config terminal //进入全局配置模式

Switch(config)#vlan 30 //创建vlan30
Switch(config-vlan)#exit //退出
Switch(config)#vlan 40 //创建vlan40
Switch(config-vlan)#exit //退出

Switch(config)#int fastEthernet 0/2  //进入端口f0/2
Switch(config-if)#switchport mode access //设置接入模式
Switch(config-if)#switchport access vlan 30 //将接口加入vlan10
Switch(config-if)#exit //退出

Switch(config)#int fastEthernet 0/3 //进入端口f0/3
Switch(config-if)# switchport mode access //设置接入模式
Switch(config-if)# switchport access vlan 40 //将接口加入vlan20
Switch(config-if)# exit //退出

Switch(config)#int fastEthernet 0/1 //进入端口f0/1
Switch(config-if)#switchport mode trunk  //设置为中继模式

3.SW3配置思路:
(1)设置vlan10、vlan20、vlan30、vlan40
(2)接口f0/1和f0/2设置trunk
(3)进入vlan10设置网关192.168.22.190,进入vlan20设置网关192.168.22.126,进入vlan30设置网关192.168.22.222,进入vlan40设置网关192.168.22.254
(4)开启三层交换机路由功能,开启dhcp功能
(5)配置地址池内容
设置vlan10地址池,网段192.168.22.128/26,子网掩码255.255.255.192,网关192.168.22.190,dns为8.8.8.8。
设置vlan20地址池,网段192.168.22.0/25,子网掩码255.255.255.128,网关192.168.22.126,dns为8.8.8.8。
设置vlan30地址池,网段192.168.22.192/27,子网掩码255.255.255.224,网关192.168.22.222,dns为8.8.8.8。
设置vlan40地址池,网段192.168.22.224/27,子网掩码255.255.255.224,网关192.168.22.254,dns为8.8.8.8。

Switch>enable //进入特权模式
Switch#config terminal //进入全局配置模式
Switch(config)#vlan 10 //创建vlan10
Switch(config-vlan)#vlan 20 //创建vlan20
Switch(config-vlan)#vlan 30 //创建vlan30
Switch(config-vlan)#vlan 40 //创建vlan40
Switch(config-vlan)# exit  //退出

Switch(config)#interface vlan 10 //进入vlan10
Switch(config-if)#no shutdown //开启端口
Switch(config-if)#ip address 192.168.22.190 255.255.255.192 //设置vlan10的网关
Switch(config-if)#exit //退出

Switch(config)#interface vlan 20 //进入vlan20
Switch(config-if)#no shutdown //开启端口
Switch(config-if)#ip address 192.168.22.126 255.255.255.128 //设置vlan20的网关
Switch(config-if)#exit //退出

Switch(config)#interface vlan 30 //进入vlan30
Switch(config-if)#no shutdown //开启端口
Switch(config-if)#ip address 192.168.22.222 255.255.255.224 //设置vlan30的网关
Switch(config-if)#exit //退出

Switch(config)#interface vlan 40 //进入vlan40
Switch(config-if)#no shutdown //开启端口
Switch(config-if)#ip address 192.168.22.54  255.255.255.224 //设置vlan40的网关
Switch(config-if)#exit //退出

Switch(config)#interface range fastEthernet 0/1-2 //进入端口f0/1和f0/2
Switch(config-if-range)#switchport mode trunk  //设置为中继模式
Switch(config-if)#exit //退出

Switch(config)#ip routing //开启三层交换机的路由功能
Switch(config)#service dhcp //开启dhcp服务

Switch(config)#ip dhcp pool vlan10 //设置vlan10的地址池
Switch(dhcp-config)#network 192.168.22.128 255.255.255.192 //设置vlan10网段
Switch(dhcp-config)#default-router 192.168.22.190 //设置vlan10网关
Switch(dhcp-config)#dns-server 8.8.8.8 //设置vlan10的dns
Switch(config-if)#exit //退出

Switch(config)#ip dhcp pool vlan20 //设置vlan20的地址池
Switch(dhcp-config)#network 192.168.22.0 255.255.255.128 //设置vlan20网段
Switch(dhcp-config)#default-router 192.168.22.126 //设置vlan20网关
Switch(dhcp-config)#dns-server 8.8.8.8 //设置vlan20的dns
Switch(config-if)#exit //退出

Switch(config)#ip dhcp pool vlan30 //设置vlan30的地址池
Switch(dhcp-config)#network 192.168.22.192 255.255.255.224 //设置vlan30网段
Switch(dhcp-config)#default-router 192.168.22.222 //设置vlan30网关
Switch(dhcp-config)#dns-server 8.8.8.8 //设置vlan30的dns
Switch(config-if)#exit //退出

Switch(config)#ip dhcp pool vlan40 //设置vlan40的地址池
Switch(dhcp-config)#network 192.168.22.224 255.255.255.224 //设置vlan40网段
Switch(dhcp-config)#default-router 192.168.22.254 //设置vlan40网关
Switch(dhcp-config)#dns-server 8.8.8.8 //设置vlan40的dns
Switch(config-if)#exit //退出

七、检测截图和检测命令截图
1.SW1交换机Switch#show vlan //查看vlan设置
思科拓扑--小型公司案例实施和思路。
Switch#show interfaces trunk //查看vlan的trunk设置
思科拓扑--小型公司案例实施和思路。
2.SW2交换机Switch#show vlan //查看vlan设置
思科拓扑--小型公司案例实施和思路。
Switch#show interfaces trunk //查看vlan的trunk设置
思科拓扑--小型公司案例实施和思路。
3.SW3交换机Switch#show vlan //查看vlan设置
思科拓扑--小型公司案例实施和思路。
Switch#show interfaces trunk //查看vlan的trunk设置
思科拓扑--小型公司案例实施和思路。
Switch#show running-config //查看所有设置,查看配置的网关和地址池
思科拓扑--小型公司案例实施和思路。
思科拓扑--小型公司案例实施和思路。
4.四台pc获取dhcp ip地址截图
思科拓扑--小型公司案例实施和思路。
思科拓扑--小型公司案例实施和思路。
思科拓扑--小型公司案例实施和思路。
思科拓扑--小型公司案例实施和思路。