一、首先配置拓扑图
华为拓扑----三层交换机实现dhcp功能


二、实验目的
1.让SW3三层交换机实现dhcp功能
2.在二层交换机中划分vlan10和vlan20
3.实现三层交换机的路由功能
4.可以让pc1、pc2、pc3、pc4互通,并且能够联通两个网关


三、所需设备以及相关设置
2台二层交换机、四台pc机、一台三层交换机

  1. 交换机接口划分
设备 接口 所属vlan
sw1 e0/0/3 0/0/2 e0/0/1 acc vlan10
Sw2 e0/0/3 0/0/2 e0/0/1 acc vlan20
SW3 g0/0/1 acc vlan 10
SW3 g0/0/2 vlan 20

2.sw3交换机 vlan网关设置

vlan 分配的网关ip
Vlan10 192.168.1.254/24
Vlan20 192.168.2.254/24

3.vlan10和vlan20 地址池设置

vlan 网段 网关 子网掩码 dns
vlan10 192.168.1.0 192.168.1.254 255.255.255.0 8.8.8.8
vlan20 192.168.2.0 192.168.2.254 255.255.255.0 8.8.8.8

四、配置思路及代码
1.首先把四台pc机设置dhcp功能
2.在sw1中配置和思路
思路:设置vlan10 把三个接口acc接入vlan

<Huawei>system-view //进入系统模式

[Huawei]vlan 10 //创建vlan10
[Huawei-vlan10]quit //退出

[Huawei]port-group group-member Ethernet 0/0/1 to Ethernet 0/0/3 //进入接口Ethernet 1-3
[Huawei-port-group]port link-type access    //设置接口模式为接入
[Huawei-port-group]port default vlan 10 //把接口添加入vlan10

3.在sw2中配置和思路
思路:设置vlan20 把三个接口acc接入vlan

<Huawei>system-view //进入系统模式

[Huawei]vlan 20 //创建vlan20
[Huawei-vlan20]quit //退出

[Huawei]port-group group-member Ethernet 0/0/1 to Ethernet 0/0/3 //进入接口Ethernet 1-3
[Huawei-port-group]port link-type access    //设置接口模式为接入
[Huawei-port-group]port default vlan 20 //把接口添加入vlan20

4.在sw3中配置和思路
设置vlan10和20
设置vlan10和20的ip路由地址
把两个接口加入vlan10和vlan20
设置vlan10和vlan20的地址池
让vlan10和vlan20加入dhcp
开启dhcp

<Huawei>system-view //进入系统模式

[Huawei]vlan batch 10 20 //创建vlan10和20

[Huawei]interface Vlanif 10 //进入vlan10内
[Huawei-Vlanif10]undo shutdown //开启端口
[Huawei-Vlanif10]ip add 192.168.1.254 24 //设置ip网关
[Huawei-Vlanif10]quit //退出

[Huawei]interface vlanif 20 //进入vlan20内
[Huawei-Vlanif20]undo shutdown //开启端口
[Huawei-Vlanif20]ip address 192.168.2.254 24 //设置ip网关
[Huawei-Vlanif20]quit //退出

[Huawei]interface GigabitEthernet 0/0/1 //进入端口gig1  
[Huawei-GigabitEthernet0/0/1]port link-type access //设置接口模式为接入
[Huawei-GigabitEthernet0/0/1]port default  vlan 10 //把接口添加入vlan10
[Huawei-GigabitEthernet0/0/1]quit //退出

[Huawei]interface GigabitEthernet 0/0/2 //进入端口gig2  
[Huawei-GigabitEthernet0/0/2]port link-type access //设置接口模式为接入
[Huawei-GigabitEthernet0/0/2]port default  vlan 20 //把接口添加入vlan20
[Huawei-GigabitEthernet0/0/2]quit //退出

[Huawei]ip pool vlan10 //创建地址池vlan10
[Huawei-ip-pool-vlan10]network 192.168.1.0 mask 255.255.255.0 //设置网段
[Huawei-ip-pool-vlan10]gateway-list 192.168.1.254 //设置网关
[Huawei-ip-pool-vlan10]dns-list 8.8.8.8 //设置dns
[Huawei-ip-pool-vlan10]lease day 3 //设置租约时间
[Huawei-ip-pool-vlan10]excluded-ip-address 192.168.1.253 //去除不想分配的地址
[Huawei-ip-pool-vlan10]quit //退出

[Huawei]ip pool vlan20 //创建地址池vlan20
[Huawei-ip-pool-vlan20]network 192.168.2.0 mask 255.255.255.0 //设置网段
[Huawei-ip-pool-vlan20]gateway-list 192.168.2.254 //设置网关
[Huawei-ip-pool-vlan20]dns-list 8.8.8.8 //设置dns
[Huawei-ip-pool-vlan20]lease day 3 //设置租约时间
[Huawei-ip-pool-vlan20]excluded-ip-address 192.168.2.253 //去除不想分配的地址
[Huawei-ip-pool-vlan20]quit //退出

[Huawei]interface Vlanif 10 //进入vlan10内 
[Huawei-Vlanif10]dhcp select global //在vlan10内设置dhcp为全局模式 
[Huawei-Vlanif10]quit //退出

[Huawei]interface Vlanif 20 //进入vlan20内 
[Huawei-Vlanif20]dhcp select global //在vlan20内设置dhcp为全局模式 
[Huawei-Vlanif20]quit //退出

[Huawei]dhcp enable //开启dhcp

五、检测截图和检测命令截图
1.SW1[Huawei]display vlan//检测是否添加vlan10 和 接口
华为拓扑----三层交换机实现dhcp功能
2.SW2 [Huawei]display vlan//检测是否添加vlan20 和 接口
华为拓扑----三层交换机实现dhcp功能
3.SW3 [Huawei]display vlan //检测是否添加vlan10、vlan20和 接口
华为拓扑----三层交换机实现dhcp功能
[Huawei]display current-configuration//检查所有配置
华为拓扑----三层交换机实现dhcp功能
华为拓扑----三层交换机实现dhcp功能
Pc机检测 ipconfig
华为拓扑----三层交换机实现dhcp功能