DMVPN的基本知识总结脑图:

DMVPN(一)之MGRE基本知识及案例分析配置

案例分析:

拓扑图如下:
DMVPN(一)之MGRE基本知识及案例分析配置

要求:
环境:Web IOU
DMVPN第三阶段 树状分支结构
一、R2和R9是ISP,只需配置接口IP即可,不能进行任何配置。
二、R1为总部HUB,R3和R4为分部spoke
三、R3为R5、R6的总部HUB,R5、R6位分站点spoke
四、R4为R7、R8的总部HUB,R7、R8位分站点spoke
五、无论总部还是分部都有一个环回接口作为内网
六、整个结构都运行EIGRP协议,但不能用关闭下一跳解析和水平分割实现一跳通信
七、实现R6与R7可以直接通信,不需要经过总部

分析:

1.首先,我们先需要保证公网相通,公网IP自己配置,但每个环回地址需要配置合理,因为R1需要下发汇总路由。 R3和R4指静态路由实现第一层的公网相通,通过配置默认路由实现第二层的公网相通。
2.在总部和分部配置nhrp时注意映射关系,保证分部和总部的建邻。还需要修改组播映射为伪广播,否则无法正常建邻。
3.我们在每个路由器上配置nhrp时需要注意把network-ID和tunnel key 配置为一样,保证正常通信。
4.在R3和R4上起两个隧道接口,一个接口为tunnel 0 是R1的spoke ,一个接口为tunnel 1 为下层的Hub。
5.如果我们使用的路由协议为OSPF时,则需要注意修改网络类型,MA网络下修改分部的优先级为0 DR为总部。
6.最后就是nhrp重定向,R6与R7直接通信,R6首先向R3发出地址解析请求,R3需要把这个请求重定向给R1,那么就需要在R3的tunnel 0 接口 和 tunnel 1 接口都配置ip nhrp redirect ,这样才能转发出去。R4同理配置
7.所以的总部tunnel口配置 ip nhrp redirect ,分部tunnel口配置为 ip nhrp shortcut 。

  1. nhrp协议需要一次通信来进行激活,这样才会出现标记为H的路由实现直接通信

配置:

R1配置:

interface Loopback0
 ip address 10.100.1.1 255.255.255.0
!
interface Tunnel0
 ip address 10.1.1.1 255.255.255.0
 no ip redirects
 ip nhrp map multicast dynamic
 ip nhrp network-id 100
 ip nhrp redirect
 ip summary-address eigrp 90 10.100.0.0 255.255.0.0
 tunnel source Ethernet0/0
 tunnel mode gre multipoint
 tunnel key 100
!
interface Ethernet0/0
 ip address 12.1.1.1 255.255.255.0

!
router eigrp 90
 network 10.0.0.0
!
ip route 0.0.0.0 0.0.0.0 12.1.1.2
!

R2配置:

interface Ethernet0/0
 ip address 12.1.1.2 255.255.255.0
!
interface Ethernet0/1
 ip address 23.1.1.2 255.255.255.0
!
interface Ethernet0/2
 ip address 24.1.1.2 255.255.255.0

R3配置:

interface Loopback0
 ip address 10.100.3.3 255.255.255.0
!
interface Tunnel0
 ip address 10.1.1.3 255.255.255.0
 no ip redirects
 ip nhrp map 10.1.1.1 12.1.1.1
 ip nhrp map multicast 12.1.1.1
 ip nhrp network-id 100
 ip nhrp nhs 10.1.1.1
 ip nhrp shortcut
 ip nhrp redirect
 tunnel source Ethernet0/0
 tunnel mode gre multipoint
 tunnel key 100
!
interface Tunnel1
 ip address 10.2.1.1 255.255.255.0
 no ip redirects
 ip nhrp map multicast dynamic
 ip nhrp network-id 100
 ip nhrp redirect
 tunnel source Ethernet0/1
 tunnel mode gre multipoint
 tunnel key 100
!
interface Ethernet0/0
 ip address 23.1.1.1 255.255.255.0
!
interface Ethernet0/1
 ip address 39.1.1.1 255.255.255.0
!
!
!
router eigrp 90
 network 10.0.0.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 39.1.1.2
ip route 12.1.1.0 255.255.255.0 23.1.1.2
ip route 24.1.1.0 255.255.255.0 23.1.1.2
!

R4配置:

interface Loopback0
 ip address 10.100.4.4 255.255.255.0
!
interface Tunnel0
 ip address 10.1.1.4 255.255.255.0
 no ip redirects
 ip nhrp map 10.1.1.1 12.1.1.1
 ip nhrp map multicast 12.1.1.1
 ip nhrp network-id 100
 ip nhrp nhs 10.1.1.1
 ip nhrp shortcut
 ip nhrp redirect
 tunnel source Ethernet0/0
 tunnel mode gre multipoint
 tunnel key 100
!
interface Tunnel1
 ip address 10.3.1.1 255.255.255.0
 no ip redirects
 ip nhrp map multicast dynamic
 ip nhrp network-id 100
 ip nhrp redirect
 tunnel source Ethernet0/1
 tunnel mode gre multipoint
 tunnel key 100
!
interface Ethernet0/0
 ip address 24.1.1.1 255.255.255.0
!
interface Ethernet0/1
 ip address 49.1.1.1 255.255.255.0
!

!
router eigrp 90
 network 10.0.0.0
!

ip route 0.0.0.0 0.0.0.0 49.1.1.2
ip route 12.1.1.0 255.255.255.0 24.1.1.2
ip route 23.1.1.0 255.255.255.0 24.1.1.2
!

R9配置:

interface Ethernet0/0
 ip address 39.1.1.2 255.255.255.0
!
interface Ethernet0/1
 ip address 49.1.1.2 255.255.255.0
!
interface Ethernet0/2
 ip address 59.1.1.2 255.255.255.0
!
interface Ethernet0/3
 ip address 69.1.1.2 255.255.255.0
!         
interface Ethernet1/0
 ip address 79.1.1.2 255.255.255.0
!
interface Ethernet1/1
 ip address 89.1.1.2 255.255.255.0

R5配置:

interface Loopback0
 ip address 10.100.5.5 255.255.255.0
!
interface Tunnel0
 ip address 10.2.1.5 255.255.255.0
 no ip redirects
 ip nhrp map 10.2.1.1 39.1.1.1
 ip nhrp map multicast 39.1.1.1
 ip nhrp network-id 100
 ip nhrp nhs 10.2.1.1
 ip nhrp shortcut
 tunnel source Ethernet0/0
 tunnel mode gre multipoint
 tunnel key 100
!
interface Ethernet0/0
 ip address 59.1.1.1 255.255.255.0
!
i
!
!
router eigrp 90
 network 10.0.0.0
!

ip route 0.0.0.0 0.0.0.0 59.1.1.2

R6配置:

interface Loopback0
 ip address 10.100.6.6 255.255.255.0
!
interface Tunnel0
 ip address 10.2.1.6 255.255.255.0
 no ip redirects
 ip nhrp map 10.2.1.1 39.1.1.1
 ip nhrp map multicast 39.1.1.1
 ip nhrp network-id 100
 ip nhrp nhs 10.2.1.1
 ip nhrp shortcut
 tunnel source Ethernet0/0
 tunnel mode gre multipoint
 tunnel key 100
!
interface Ethernet0/0
 ip address 69.1.1.1 255.255.255.0

!
!
router eigrp 90
 network 10.0.0.0
!

ip route 0.0.0.0 0.0.0.0 69.1.1.2
!

R7配置:

interface Loopback0
 ip address 10.100.7.7 255.255.255.0
!
interface Tunnel0
 ip address 10.3.1.7 255.255.255.0
 no ip redirects
 ip nhrp map 10.3.1.1 49.1.1.1
 ip nhrp map multicast 49.1.1.1
 ip nhrp network-id 100
 ip nhrp nhs 10.3.1.1
 ip nhrp shortcut
 tunnel source Ethernet0/0
 tunnel mode gre multipoint
 tunnel key 100
!
interface Ethernet0/0
 ip address 79.1.1.1 255.255.255.0
!
!
router eigrp 90
 network 10.0.0.0

ip route 0.0.0.0 0.0.0.0 79.1.1.2
!

R8配置:

interface Loopback0
 ip address 10.100.8.8 255.255.255.0
!
interface Tunnel0
 ip address 10.3.1.8 255.255.255.0
 no ip redirects
 ip nhrp map 10.3.1.1 49.1.1.1
 ip nhrp map multicast 49.1.1.1
 ip nhrp network-id 100
 ip nhrp nhs 10.3.1.1
 ip nhrp shortcut
 tunnel source Ethernet0/0
 tunnel mode gre multipoint
 tunnel key 100
!
interface Ethernet0/0
 ip address 89.1.1.1 255.255.255.0
!
!
router eigrp 90
 network 10.0.0.0
!

ip route 0.0.0.0 0.0.0.0 89.1.1.2
!

结果展示:

R6 traceroute R7
DMVPN(一)之MGRE基本知识及案例分析配置

R6路由表:
DMVPN(一)之MGRE基本知识及案例分析配置

出现了一条下一跳为10.3.1.7(R7 tunnel口)的去R7环回的路由 标记为H

以上就是我对DMVPN之MGRE的简单总结和配置,请大家多多指点。。谢谢~