前言

2018年1月北京某公司正式成立。公司规模70人左右。
公司目前划分部门为
总经理1台(1人)
财务部10台(财务经理1人/会计5人/收银2人/出纳2人)
销售部45台(销售经理1人/副经理1人/主管3人/40名销售专员)
人事部5台(HR经理1人/助理1人/专员3人)
运维部2台(运维经理1人/运维专员1人)
行政部5台(行政经理1人/专员2人/司机3人)
目前共计68台电脑(打印机部分由行政部负责采购和统一规划)
小张于2月应聘了该公司的运维专员一职。刚入职的第一天。运维经理让小张针对公司目前的情况进行网络规划和部署。下图为小张根据目前公司规模构建的拓扑图。

备注:各部门台式机将以1台为标准在拓扑图中体现。其余台式机请各位自行脑补
思科---北京某销售公司真实网络环境拓扑(图多杀猫)

采购:

下图为小张采购回来的计算机设备
思科---北京某销售公司真实网络环境拓扑(图多杀猫)

规划需求:

在规划拓扑图的过程中,运维经理提出以下几点要求,以下是问题摘要及解决方案:
1公司内网除服务器为静态IP地址。其余全部为DHCP动态获取IP
Question:运维经理希望在日后运维工作中。因IP冲突及管理的工作占比需要尽可能的缩小
Answer:我们可以启用DHCP服务器,将公司内网除服务器外其余所有终端设备一律采用IP自动分配原则


2实现公司内网各VLAN间的互通
Question:为了实现信息共享,各个部门希望彼此可以通过共享访问/FTP服务器来达到数据的最大化共享功能,以便提高工作效率及必要的透明度(财务及销售部)
Answer:我们将每个部门划分为不同的VLAN广播区域。让他们彼此之间进行VLAN间通信即可。这样做的好处是.既能提高交换机的工作效率,又可以在今后的运维工作中,有区域性的排查问题


3公司WEB服务器的搭建
Question:现在是互联网时代,公司的门面很大程度上是在网络上进行宣传的。那么我们在互联网中的门面就是我们的公司网站。请问小张,如果我们公司要搭建WEB服务器的话,需要具备哪些条件?
Answer:
对于这个问题来说。我觉得我们得准备入下步骤:
1:DNS服务器的搭建
2:WEB服务器的搭建
工作原理:这两台服务器的作用可以说是互帮互助的。WEB为用户提供页面的访问服务,而DNS服务器则将网站域名解析为IP地址,供WEB服务器分析。
因为我们在搜索一个网站的时候,如果全部输入IP地址。那么我们根本记不住几个。如果变成一个名称的话,那就方便记住多了。因此DNS-WEB的性质往往是相辅相成的。


部署:

**二层交换机配置

涉及技术:
VLAN,access,trunk

涉及命令
创建VLAN
SW0(config)#vlan10
进入接口模式/划分VLAN
SW0(config)#interface fastEthernet 0/1(进入单一接口)
或者
SW0(config)#interface range f0/1,f0/2(进入多接口---连续接口用“-”,非连续接口用“,”)

access/trunk链路
SW0(config-if-range)#switchport mode trunk****


例如SW1的配置如下:
SW1#conf(双回车)
SW1(config)#vlan 10
SW1(config-vlan)#vlan 20
SW1(config-vlan)#vlan 30
SW1(config-vlan)#vlan 40
SW1(config-vlan)#vlan 50
SW1(config-vlan)#vlan 60
SW1(config-vlan)#vlan 70
SW1(config-vlan)#exit
SW1(config)#interface fastEthernet 0/1
SW1(config-if)#switchport mode access
SW1(config-if)#switchport access vlan 10
SW1(config-if)#exit
SW1(config)#interface fastEthernet 0/2
SW1(config-if)#switchport mode access
SW1(config-if)#switchport access vlan 20
SW1(config-if)#exit
SW1(config)#interface range f0/10,f0/11,f0/4
SW1(config-if-range)#switchport mode trunk


验证命令:
Switch#show vlan(显示当前VLAN配置信息)

思科---北京某销售公司真实网络环境拓扑(图多杀猫)


Switch#show interfaces trunk(显示当前trunk对应接口信息)
思科---北京某销售公司真实网络环境拓扑(图多杀猫)

其余2层交换机SW配置全部一致,这里便不再过多讲述。


三层交换机配置

涉及技术:
VLAN,虚拟接口,trunk,路由中继,RIP,开启三层功能(ip routing/no switchport)

涉及命令:
创建虚拟接口并为该接口配置其对应VLAN的网关IP地址
MS0(config)#interface vlan 10
MS0(config-if)#ip add
MS0(config-if)#ip address 192.168.10.254 255.255.255.0


Trunk
这里之所以还提到trunk,是因在思科多层交换机中。为端口配置trunk链路时,需要提前为其指定封装协议。
MS0(config-if-range)#switchport trunk encapsulation dot1q
为其指定为dot1q(802.1q)封装协议
扩展知识:
目前有两种封装协议1-ISL(思科私有协议) 2-802.1(公有协议)
之所以没有用ISL协议.是因为如果对接设备为非思科设备时候,如果启用私有协议。则会导致彼此不兼容的问题。因此这里还是建议用共有协议比较妥当。
MS0(config-if-range)#switchport mode trunk


路由中继

当DHCP服务器与DHCP客户端不在同一网段的时候,就需要用到路由中继功能。
我们俗称:“好心人”
其定义也通俗易懂。开启路由中继功能就相当于为其设置一个帮忙找路的人,找什么路呢?找去往DHCP服务器IP地址指向的路。

MS0(config)#int vlan 10(VLAN 20/30/40/50同理)
MS0(config-if)#ip helper-address 192.168.70.231
ip helper-address 中继功能
192.168.70.231 DHCP服务器IP地址
备注:由于VLAN60/70全部为服务器,服务器都是设置为静态IP地址的。因此不需要借助DHCP自动分配功能。


开启三层功能

MS0(config)#ip routing

备注:简单的一条命令,但这条命令至关重要。当多层交换机当二层交换机来使用的时候,我们可以不做这条配置。但是当我们需要它开启三层功能(网络层)的时候,我们就需要通过这条命令来开启其三层的转发功能了。


以下是MS0的详细配置:
MS0(config)#vlan 10
MS0(config-vlan)#vlan 20
MS0(config-vlan)#vlan 30
MS0(config-vlan)#vlan 40
MS0(config-vlan)#vlan 50
MS0(config-vlan)#vlan 60
MS0(config-vlan)#vlan 70
MS0(config-vlan)#exit
MS0(config)#ip routing
MS0(config)#int range f0/3-f0/6
MS0(config-if-range)#switchport trunk encapsulation dot1q
MS0(config-if-range)#switchport mode trunk
MS0(config-if-range)#exit
MS0(config)#int vlan 10
MS0(config-if)#ip add 192.168.10.254 255.255.255.0
MS0(config-if)#ip helper-address 192.168.70.231
MS0(config-if)#int vlan 20
MS0(config-if)#ip add 192.168.20.254 255.255.255.0
MS0(config-if)#ip helper-address 192.168.70.231
MS0(config-if)#int vlan 30
MS0(config-if)#ip add 192.168.30.254 255.255.255.0
MS0(config-if)#ip helper-address 192.168.70.231
MS0(config-if)#int vlan 40
MS0(config-if)#ip add 192.168.40.254 255.255.255.0
MS0(config-if)#ip helper-address 192.168.70.231
MS0(config-if)#int vlan 50
MS0(config-if)#ip add 192.168.50.254 255.255.255.0
MS0(config-if)#ip helper-address 192.168.70.231
MS0(config-if)#int vlan 60
MS0(config-if)#ip add 192.168.60.254 255.255.255.0
MS0(config-if)#int vlan 70
MS0(config-if)#ip add 192.168.70.254 255.255.255.0
MS0(config-if)#exit


验证命令:
MS0#show ip interface brief(显示当前所有接口的IP地址配置信息)
思科---北京某销售公司真实网络环境拓扑(图多杀猫)


DHCP/DNS/WEB服务器配置


DHCP服务器

由于我们使用的是Cisco Packet Tracer模拟器,因此现在这里只能为大家提供模拟器环境下的配置方法。但是实际上的配置肯定不是这样的。目前服务器操作系统有两大板块:1Windows server
2linux 。像Windows server的话,一般我们惯用的是Server2012.需要在其系统内开启对应的模块,才能提供相应的服务。具体实际如何配置,这里不做细表。

配置详解:
思科---北京某销售公司真实网络环境拓扑(图多杀猫)


待成功开启后,我们不妨现在前去各自部门的主机上进行下测试。查看下DHCP功能是否开启。
如下图所示。总经理的高级苹果一体机已经可以自动获取到我们事先规划好的IP地址了。
思科---北京某销售公司真实网络环境拓扑(图多杀猫)


其余部门这里不做细表,经检查也是全部获取完毕的状态。毕竟老板永远要放在第一位


DNS/WEB服务器配置

DNS服务器配置:
思科---北京某销售公司真实网络环境拓扑(图多杀猫)


WEB服务器配置:
思科---北京某销售公司真实网络环境拓扑(图多杀猫)


公司边界路由器配置

前面我们先为路由器各自接口配置IP地址及子网掩码。这里不做细表。

接口 IP地址 子网掩码
G0/0 192.168.100. 2 255.255.255.0
G0/2 100.10.10.2 255.255.255.0

备注:思科路由器的物理接口默认是关闭状态的,需要通过no shutdown来激活该端口才行

配置完毕后可以通过show ip interface brief 来查询验证,如下图:

思科---北京某销售公司真实网络环境拓扑(图多杀猫)


涉及技术:
RIP

涉及命令:
NAT-Router(config)#router rip(开启RIP协议模式)
NAT-Router(config-router)#version 2(选用版本2,即RIPv2)
NAT-Router(config-router)#network 192.168.100.0 (将192.168.100.0的网段宣告进RIP协议中)
NAT-Router(config-router)#network 100.0.0.0(将100.0.0.0的网段宣告进RIP协议中)


此外,我们之前配置过的3层交换机此处也需要进行下配置RIP的工作,并且得在F0/10口配置各IP地址。如下图所示接口:
思科---北京某销售公司真实网络环境拓扑(图多杀猫)

F0/10配置IP地址涉及命令:
MS0(config)#interface fastEthernet 0/10
MS0(config-if)#no switchport
此条命令至关重要,如果不输入此条命令,思科的3层交换机是无法配置IP地址的
MS0(config-if)#
MS0(config-if)#ip add 192.168.100.1 255.255.255.0
MS0(config-if)#no shutdown

MS0多层交换机RIP配置命令:
MS0(config)#router rip
MS0(config-router)#version 2
MS0(config-router)#network 192.168.10.0
MS0(config-router)#network 192.168.20.0
MS0(config-router)#network 192.168.30.0
MS0(config-router)#network 192.168.40.0
MS0(config-router)#network 192.168.50.0
MS0(config-router)#network 192.168.60.0
MS0(config-router)#network 192.168.70.0
MS0(config-router)#network 192.168.100.0
MS0(config-router)#


验证命令
我们在公司内网的边界路由器上进行下验证。以下是验证命令和截图:
如图所示,在边界路由器NAT-Router上面,已经学习到了来自MS0多层交换机上的所有网段。
即"R"开头的网络段全部来自于MS0这台交换机。
NAT-Router#show ip route
思科---北京某销售公司真实网络环境拓扑(图多杀猫)


互通验证测试
配置完毕后,回到自己的工位。利用自己的电脑去尝试访问NAT-Router G0/0接口的IP地址
发现已经可以互通。其余部门挨个测试,也可以实现互通。至此公司整个内部网络环境架构已经搭建完毕。

思科---北京某销售公司真实网络环境拓扑(图多杀猫)


WEB站点访问测试
1-确认每个部门获取的IP地址中,DNS服务器的地址是否正确。如下图所示:
思科---北京某销售公司真实网络环境拓扑(图多杀猫)


2-验证域名互通性,如下图所示,公司网站www.company.com是通过DNS服务器所解析出来的。
思科---北京某销售公司真实网络环境拓扑(图多杀猫)

3-打开IE浏览器,输入公司的网站域名。www.company.com测试下结果。如下图所示:
思科---北京某销售公司真实网络环境拓扑(图多杀猫)

网页已经可以正常显示了。至于内容方面,就交给网页设计的同事们去搞定吧。网络方面我们已经给你们提供好了。

至此公司整体网络环境就架设完毕了。
欢迎大家热心点评,我会虚心改正。由于本人经验不足,属于网络小白。还请大神多多指正。

张涤非