MUX VLAN
原理:
同一个子网内的设备(IP层面),但是不在同一个vlan(2、3、10),可以通过调整vlan的角色使其通信或者不通信,节省IP
两大类VLAN:主vlan(主接口)、子vlan(组vlan和隔离性VLAN)
1)主接口可以和所有接口通信
2)同一互组vlan内的设备可以互通
3)不同的组vVLAN是不能通信的
4)隔离性vlan内的主机只能和主接口通信

MUX VLAN的配置实例:
路由交换之MUX VLAN(华为)
1)创建对应的VLAN

[SW1]vlan batch 10 20 30 100 //先创建对应的VLAN
[SW2]vlan batch 10 20 30 100

2)定义VLAN角色(SW1和SW2)

vlan 100 //子VLAN需要在主VLAN下定义
mux-vlan //该VLAN 100成为主VLAN
subordinate separate 30 //VLAN30 成为隔离VLAN
subordinate group 10 20 //VLAN 10和20成为不同的组VLAN

3)交换机互联接口实施Trunk:

interface GigabitEthernet0/0/10
port link-type trunk
port trunk allow-pass vlan 2 to 4094

4)关联MUX-VLAN:
SW1:

interface GigabitEthernet0/0/1
port link-type access
port default vlan 10 //该端口划分到VLAN10,就拥有了VLAN10所被定义的角色
port mux-vlan enable //必须使能

interface GigabitEthernet0/0/2
port link-type access
port default vlan 10
port mux-vlan enable

interface GigabitEthernet0/0/3
port link-type access
port default vlan 20
port mux-vlan enable

interface GigabitEthernet0/0/4
port link-type access
port default vlan 30
port mux-vlan enable

interface GigabitEthernet0/0/5
port link-type access
port default vlan 30
port mux-vlan enable

SW2:

interface GigabitEthernet0/0/1
port link-type access
port default vlan 100
port mux-vlan enable

5)验证:

[SW1]display mux-vlan
Principal Subordinate Type Interface
~~-----------------------------------------------------------------------------~~
100 - principal
100 30 separate GigabitEthernet0/0/4 GigabitEthernet0/0/5
100 10 group GigabitEthernet0/0/1 GigabitEthernet0/0/2
100 20 group GigabitEthernet0/0/3

[SW2]display mux-vlan
Principal Subordinate Type Interface

100 - principal GigabitEthernet0/0/1
100 30 separate
100 10 group
100 20 group

[SW1]display mac-address mux
MAC address table of slot 0:

MAC Address VLAN/ PEVLAN CEVLAN Port Type LSP/LSR-ID
VSI/SI MAC-Tunnel

5489-98e6-4e87 10 - - GE0/0/1 dynamic 0/-
5489-98e6-4e87 100 - - GE0/0/1 dynamic 0/-
5489-98a6-2530 10 - - GE0/0/2 dynamic 0/-
5489-98a6-2530 100 - - GE0/0/2 dynamic 0/-
5489-98a5-24b6 30 - - GE0/0/4 dynamic 0/-
5489-98a5-24b6 100 - - GE0/0/4 dynamic 0/-
5489-987c-6fa6 100 - - GE0/0/10 dynamic 0/-
Total matching items on slot 0 displayed = 7