OSPF(Open Shortest Path First,开放式最短路径优先)协议,是目前网络中应用最广泛的路由协议之一。属于内部网关路由协议,能够适应各种规模的网络环境,是典型的链路状态(link-state)协议。

    OSPF 路由协议通过向全网扩散本设备的链路状态信息,使网络中每台设备最终同步一个具有全网链路状态的数据库(LSDB),然后路由器采用 SPF 算法,以自己为根,计算到达其他网络的最短路径,最终形成全网路由信息。

    OSPF 属于无类路由协议,支持 VLSM(变长子网掩码)。OSPF 是以组播的形式进行链路状态的通告的。在大模型的网络环境中,OSPF 支持区域的划分,将网络进行合理规划。划分区域时必须存在 area0(骨干区域)。其他区域和骨干区域直接相连,或通过虚链路的方式连接。

    wKioL1gpKsCgswdsAADKveIvGeo262.png


步骤一 在路由器和三层交换机配置IP地址

   

switch(config)#hostname S3750

S3750(config)#vlan 10

S3750(config-vlan)#exit

S3750(config)#vlan 50

S3750(config-vlan)#exit

S3750(config)#interface f0/1

S3750(config-if)#switchport access vlan 10

S3750(config-if)#exit

S3750(config)#interface f0/2

S3750(config-if)#switchport access vlan 50

S3750(config-if)#exit

S3750(config)#interface vlan 10

S3750(config-if)#ip address 172.16.1.2 255.255.255.0

S3750(config-if)#no shutdown

S3750(config-if)#exit

S3750(config)#interface vlan 50

S3750(config-if)#ip address 172.16.5.1 255.255.255.0

S3750(config-if)#no shutdown

S3750(config-if)#exit

wKioL1gpLcrBm7rqAAAqoYNpnlE206.png

RouterA如同B。

步骤二 配置OSPF路由协议。

wKiom1gpLjyi0fdeAAAUkx6YoMw670.png

交换机和Router如同。

步骤三 验证测试。

wKioL1gpLnnRNhJeAAAfi18Sylg111.png

wKiom1gpLpCh0zYwAAATu9GEj9g509.png

注意事项:

(1)在申明直连网段时,注意要写该网段的反掩码。

(2)选择时需要选择三层交换机,因为它可以同时执行多个vlan。

总结:

链路状态路由协议

OSPF--

开放式最短路径优先

链路状态路由协议

OSPF--

开放式最短路径优先

     OSPF——开放式最短路径优先。实现信息的共享和传递。