网络拓扑

大型网络之公司内部局域网

-----------------------------------点击下面看大图----------------------------------

网络拓扑说明:这是一个公司内部网络拓扑,三层交换机Switch1Switch2组成冗余核心层网络,相当于企业内部的中心机房。下面二层交换机则划分出不同部门(如财务部、销售部等)的相应Vlan。在Router1上做DHCP,是下面不同部门可以获得相应VlanIP地址。

(注意:此实验我是用Packet做的实验拓扑,用小凡做的实验步骤,建议大家也用小凡工具)

VPCS V0/1 <----> Switch3 F0/1

VPCS V0/2 <----> Switch3 F0/2

VPCS V0/3 <----> Switch4 F0/3

VPCS V0/4 <----> Switch4 F0/4

VPCS V0/5 <----> Switch5 F0/5

VPCS V0/6 <----> Switch5 F0/6

VPCS V0/7 <----> Switch6 F0/7

VPCS P0/0 <----> Switch6 F0/8

Switch1 F0/1 <----> Switch2 F0/1

Switch1 F0/2 <----> Switch2 F0/2

Switch1 F0/10 <----> Switch3 F0/10

Switch1 F0/11 <----> Switch4 F0/11

Switch1 F0/12 <----> Switch5 F0/12

Switch1 F0/13 <----> Switch6 F0/13

Switch2 F0/11 <----> Switch3 F0/11

Switch2 F0/12 <----> Switch4 F0/12

Switch2 F0/13 <----> Switch5 F0/13

Switch2 F0/14 <----> Switch6 F0/14

Router1 F0/0 <----> Switch1 F0/5

Router1 F1/0 <----> Switch2 F0/5

Router1 F2/0 <----> Router2 F0/0

实验步骤:

一、 Switch1的配置

1、交换机之间链路开Trunk

Switch1(config)#inter rang f0/1 - 2

Switch1(config-if-range)#swi mode trunk

Switch1(config-if-range)#no shut

Switch1(config)#inter rang f0/10 - 13

Switch1(config-if-range)#swi mode trunk

Switch1(config-if-range)#no shut

2、配置VTP,使交换机之间学习到相同的VLAN

Switch1(vlan)#vtp d

Switch1(vlan)#vtp domain jj

Changing VTP domain name from NULL to jj

3、配置以太网通道(注意:以太网通道捆绑的线路数是22的倍数,Cisco交换机最多捆绑8个端口)

Switch1(config)#inter rang f0/1 – 2

Switch1(config-if-range)#channel-group 1 mode on

Creating a port-channel interface Port-channel1

4、配置STP生成树协议

Switch1(config)#spanning-tree vlan 2 priority 4096

Switch1(config)#spanning-tree vlan 3 priority 4096

Switch1(config)#spanning-tree vlan 4 priority 8192

Switch1(config)#spanning-tree vlan 5 priority 8192

5、配置相应的VLANIP,主要作用是实现不同VLANPC互通,并且还作为PC的网关。但在这里做了HSRP指定的有一个虚拟网关,所以PC的网关用虚拟网关。

Switch1(config)#inter vl 2

Switch1(config-if)#ip add 20.0.0.11 255.0.0.0

Switch1(config-if)#no shut

Switch1(config-if)#standby 2 ip 20.0.0.10

Switch1(config-if)#standby 2 priority 200

Switch1(config-if)#standby 2 preempt

Switch1(config)#inter vl 3

Switch1(config-if)#ip add 30.0.0.11 255.0.0.0

Switch1(config-if)#no shut

Switch1(config-if)#standby 3 ip 30.0.0.10

Switch1(config-if)#standby 3 priority 200

Switch1(config-if)#standby 3 preempt

Switch1(config)#inter vl 4

Switch1(config-if)#ip add 40.0.0.11 255.0.0.0

Switch1(config-if)#no shut

Switch1(config-if)#standby 4 ip 40.0.0.10

Switch1(config-if)#standby 4 priority 150

Switch1(config)#inter vl 5

Switch1(config-if)#ip add 50.0.0.11 255.0.0.0

Switch1(config-if)#no shut

Switch1(config-if)#standby 5 ip 50.0.0.10

Switch1(config-if)#standby 5 priority 200

6、宣告RIP

Switch1(config)#router rip

Switch1(config-router)#version 2

Switch1(config-router)#no auto-summary

Switch1(config-router)#network 20.0.0.0

Switch1(config-router)#network 30.0.0.0

Switch1(config-router)#network 40.0.0.0

Switch1(config-router)#network 60.0.0.0

Switch1(config-router)#network 50.0.0.0

7、配置DHCP中继,PC机请求DHCP地址时发送的是广播信息,VLAN2 VLAN3 的请求信息到达Switch1时,由于此时Switch1已经开启路由功能,不转发广播信息,所以Vlan23的请求IP地址信息就会被拒绝。这时配置DHCP中继,Vlan23的请求信息到达Switch1时,Switch1就把广播信息定向转换为单播转发出去,这样Vlan23的请求就能到达Router1.这也叫定向广播。

Switch1(config)#inter vl 2

Switch1(config-if)#ip helper-address 60.0.0.2

Switch1(config)#inter vl 3

Switch1(config-if)#ip helper-address 60.0.0.2

Switch1(config)#inter vl 4

Switch1(config-if)# ip helper-address 60.0.0.2

Switch1(config)#inter vl 5

Switch1(config-if)# ip helper-address 60.0.0.2

8、在Switch1上配置到与路由器相连的默认路由,此时Switch1开启路由功能就相当于路由器,所以想要pingRouter2右边,就要配置默认路由。

Switch1(config)#ip route 0.0.0.0 0.0.0.0 60.0.0.2

9、在Switch1上开启路由接口

Switch1(config)#inter f0/5

Switch1 (config-if)#no switchport

Switch1config-if)#ip add 60.0.0.1 255.0.0.0

Switch1 (config-if)#no shut

二、 Switch2的配置(与Switch1原理相同,配置也相类似)

Switch2(config)#inter rang f0/1 - 2

Switch2(config-if-range)#swi mode trunk

Switch2(config-if-range)#no shut

Switch2(config)#

Switch2(config)#inter rang f0/11 - 14

Switch2(config-if-range)#swi mode trunk

Switch2(config-if-range)#no shut

Switch2(config-if-range)#exi

Switch2(config)#inter rang f0/1 - 2

Switch2(config-if-range)#channel-group 1 mode on

Creating a port-channel interface Port-channel1

Switch2(config)#spanning-tree vlan 2 priority 8192

Switch2(config)#spanning-tree vlan 3 priority 8192

Switch2(config)#spanning-tree vlan 4 priority 4096

Switch2(config)#spanning-tree vlan 5 priority 4096

Switch2(config)#inter vl 2

Switch2(config-if)#ip add 20.0.0.12 255.0.0.0

Switch2(config-if)#no shut

Switch2(config-if)#standby 2 ip 20.0.0.10

Switch2(config-if)#standby 2 priority 150

Switch2(config)#inter vl 3

Switch2(config-if)#ip add 30.0.0.12 255.0.0.0

Switch2(config-if)#no shut

Switch2(config-if)#standby 3 ip 30.0.0.10

Switch2(config-if)#standby 3 priority 150

Switch2(config)#inter vl 4

Switch2(config-if)#ip add 40.0.0.12 255.0.0.0

Switch2(config-if)#no shut

Switch2(config-if)#standby 4 ip 40.0.0.10

Switch2(config-if)#standby 4 priority 200

Switch2(config)#inter vl 5

Switch2(config-if)#ip add 50.0.0.12 255.0.0.0

Switch2(config-if)#no shut

Switch2(config-if)#standby 5 ip 50.0.0.10

Switch2(config-if)#standby 5 priority 200

Switch2(config)#router rip

Switch2(config-router)#version 2

Switch2(config-router)#no auto-summary

Switch2(config-router)#network 20.0.0.0

Switch2(config-router)#network 30.0.0.0

Switch2(config-router)#network 40.0.0.0

Switch2(config-router)#network 50.0.0.0

Switch2(config-router)#network 70.0.0.0

Switch1(config)#inter vl 2

Switch1(config-if)#ip helper-address 70.0.0.2

Switch1(config)#inter vl 3

Switch1(config-if)#ip helper-address 70.0.0.2

Switch2(config)#inter vl 4

Switch2(config-if)#ip helper-address 70.0.0.2

Switch2(config)#inter vl 5

Switch2(config-if)#ip helper-address 70.0.0.2

Switch2(config)#ip route 0.0.0.0 0.0.0.0 70.0.0.2

Switch2(config)#inter f0/5

Switch2 (config-if)#no switchport

Switch2 (config-if)#ip add 70.0.0.1 255.0.0.0

Switch2 (config-if)#no shut

三、 交换机3 6配置

Switch3(config)#inter rang f0/10 - 11

Switch3(config-if-range)#swi mode trunk

Switch3(config-if-range)#no shut

Switch4(config)#inter rang f0/11 - 12

Switch4(config-if-range)#swi mode trunk

Switch4(config-if-range)#no shut

Switch4(config)#f-range)#exi

Switch5(config)#inter rang f0/12 - 13

Switch5(config-if-range)#swi mode trunk

Switch5(config-if-range)#no shut

Switch5(config-if-range)#exi

Switch6(config)#inter rang f0/13 - 14

Switch6(config-if-range)#swi mode trunk

Switch6(config-if-range)#no shut

Switch6(config-if-range)#exi

四、 Router1的配置

1、配置IP地址

Router1(config)#inter f0/0

Router(config-if)#ip add 60.0.0.2 255.0.0.0

Router(config-if)#no shut

Router(config)#inter f1/0

Router(config-if)#ip add 70.0.0.2 255.0.0.0

Router(config-if)#no shut

Router(config)#inter f2/0

Router(config-if)#ip add 80.0.0.1 255.0.0.0

Router(config-if)#no shut

2、配置IP地址池

Router1(config)#ip dhcp pool vl2

Router1(dhcp-config)#network 20.0.0.0 255.0.0.0

Router1(dhcp-config)#default-router 20.0.0.10

Router1(config)#ip dhcp pool vl3

Router1(dhcp-config)#network 30.0.0.0 255.0.0.0

Router1(dhcp-config)#default-router 30.0.0.10

Router1(config)#ip dhcp pool vl4

Router1(dhcp-config)#network 40.0.0.0 255.0.0.0

Router1(dhcp-config)#default-router 40.0.0.10

Router1(config)#ip dhcp pool vl5

Router1(dhcp-config)#network 50.0.0.0 255.0.0.0

Router1(dhcp-config)#default-router 50.0.0.10

3、配置PAT,允许公司内部网访问外网

R1(config)#access-list 10 permit any

R1(config)#ip nat pool pat 80.0.0.2 80.0.0.2 netmask 255.0.0.0

R1(config)#ip nat inside source list 10 pool jj overload

R1(config)#inter f0/0

R1(config-if)#ip nat in

R1(config)#inter f1/0

R1(config-if)#ip nat in

R1(config)#inter f2/0

R1(config-if)#ip nat outside

R1(config)#noip route 0.0.0.0 0.0.0.0 80.0.0.2(这个IP地址一般都为外网合法的IP地址)

4、宣告RIP

Router1(config)#router rip

Router1(config-router)#version 2

Router1(config-router)#network 60.0.0.0

Router1(config-router)#network 70.0.0.0

 

 

 

 

本文出自 “技术狼人-袁留俊” 博客,转载请务必保留此出处!

http://yuanliujun.blog.51cto.com/1947254/411214